Forum

Support des Modules souci vidéo youtube

FrancisH Membre non connecté

Booster Bazooka

Rang

Avatar

Inscrit le : 22/09/2017 à 11h03

Messages: 113

Le 12/04/2020 à 07h49

Reprise du message précédent

Bonjour,
Merci pour vos réponses, je ferai un essai sur mon site test cet AM.
Bon week-end Pascal....
Et comme Babsolune l'écrit
RESTEZ CHEZ VOUS.
Francis.



Cordialement ;)

Francis
Site web    
FrancisH Membre non connecté

Booster Bazooka

Rang

Avatar

Inscrit le : 22/09/2017 à 11h03

Messages: 113

Le 19/04/2020 à 06h45
Bonjour,.
Essai hier et tout me semble OK.

Un grand merci pour ce boulot.

Francis



Cordialement ;)

Francis
Site web    
FrancisH Membre non connecté

Booster Bazooka

Rang

Avatar

Inscrit le : 22/09/2017 à 11h03

Messages: 113

Le 02/05/2020 à 19h16
Bonjour,
Test concluant sur mes 5 sites ......
Merci



Cordialement ;)

Francis
Site web    
MickaelFR Membre non connecté

Booster Fusée

Rang

Avatar

Inscrit le : 20/01/2014 à 11h01

Messages: 1669

Le 02/05/2020 à 21h54
Salut.

Me concernant, rien ne fonctionne avec la 5.2.6 (fichier pa défaut pour tester). ça fait comme avant dans le V à la place de EMBED.

Avec une erreur fatale en plus

Code TEXT :
Fatale : invalid query. (ERRNO 1048) Column 'mime_type' cannot be nullquery: INSERT INTO phpboost_media (idcat, iduser, timestamp, name, contents, url, poster, mime_type, infos, width, height) VALUES (1, '1', 1588449048, 'Présentation du Mack Anthem 64T 2020 - Intérieur et extérieur', 'Présentation du nouveau Mack', 'https://www.youtube.com/watch?v=bjoffxnfsZs', '', NULL, 2, '800', 570);
[0] /kernel/framework/io/db/driver/mysql/MySQLQuerier.class.php:33 - MySQLQuerier->execute(string, array)
[1] /kernel/framework/io/db/DBQuerier.class.php:86 - MySQLQuerier->inject(string, array)
[2] /media/media_action.php:418 - DBQuerier->insert(string, array)
[URL] /media/media_action.php


ça fonctionne seulement avec le lien dans intégrer (même avec embed)

Lien direct, et raccourcis, erreur. Edité par MickaelFR Le 02/05/2020 à 22h04
babsolune Membre non connecté

Modérateur

Rang

Avatar

Equipe Graphique

Inscrit le : 16/05/2008 à 12h52

Messages: 2776

Le 03/05/2020 à 04h10
Plop
Citation :
ça fait comme avant dans le V à la place de EMBED.

Hem?

tu as du oublié un fichier/refresh

la catégorie est bien en vidéo? c'est une maj de l'item ou un nouvel item ?

testé avec le lien de la page
https://www.youtube.com/watch?v=bjoffxnfsZs
: résultat sur le site démo


Pour un support plus efficace, pensez à déclarer dans votre profil, le lien vers votre site
ban_wind
Site web    
MickaelFR Membre non connecté

Booster Fusée

Rang

Avatar

Inscrit le : 20/01/2014 à 11h01

Messages: 1669

Le 03/05/2020 à 10h01
Salut.

Tout est OK pour l'ajout au final, mais j'ai un autre soucis :D

La vidéo en ajout est apparente ..
Les anciennes disparaissent ! (elles y sont, mais reviennent en supprimant la " position:relative " par exemple (c'est vraiment un exemple) ..

Edt :

Avec ce CSS :

Code CSS :
/*
* Surchargez ce fichier dans votre thème pour personnaliser le module
* https://www.phpboost.com/wiki/structure-d-un-theme#paragraph-le-repertoire-modules
*/
a.media-flv {
    display: block;
    margin: 0.618em auto;
}
.media-content {
    position: relative;
    max-width: 100%;
    margin-bottom: 2em;
    text-align: center;
}
.media-content object,
.media-content embed,
.media-content video,
.media-content iframe,
.media-content [class$="-player"] {
    position: relative;
    max-width: 100%;
}
/* MODIFICATIONS */
.block {    
     box-shadow:none;     
}
#desc-background-media {
    padding: 20px;
    border-radius: 20px;
    margin-bottom: 2em;
    background-color: #fff;
    box-shadow: 0 0 12px 0 #ddd;
}
#desc-content-background-media {
    background-color: #fff;
    padding: 20px;
    border: 1px solid #366393;
    border-radius: 20px;
    width: max-content;
    align-content: right;
    align-items: right;
    box-shadow: 0 0 12px 0 #ddd;
}
.media-picture {
    max-width: 40%;
    float: right;
    margin: 0 0 2em 2em;
}
/* FIN MODIFICATIONS */                                
 


J'ai les vidéos qui apparaissent normalement, taille souhaitée, SAUF les nouvelles qui sont d'une taille ridicule (soucis avec media-content et media-content objet sans doute)

Avec le CSS de base, les anciennes vidéos n'apparaissent plus QUE les nouvelles .. C'est bizarre.

A noter que mes TPL sont modifié, mais ça ne doit pas jouer en théorie.

Erreur avec le lien court de Youtube

Code TEXT :
Suggestion : Undefined index: mime_type
 
 
[0] /media/media_action.php:392


https://www.planet-truck.fr/media/media.php?id=322

Quand je passe par le lien dans intégrer et que je change par V le EMBED, tout semble rentrer dans l'ordre.
j'ai écrasé plusieurs fois les fichiers PHP, mais en vain.
Il y a un problème entre les anciennes et nouvelles vidéos, et un soucis d'intégration de lien (selon le lien) Edité par MickaelFR Le 03/05/2020 à 10h24
babsolune Membre non connecté

Modérateur

Rang

Avatar

Equipe Graphique

Inscrit le : 16/05/2008 à 12h52

Messages: 2776

Le 03/05/2020 à 12h09
heu là techniquement sur ton lien, aucune modif n'est passée.

Il faut re-valider les video avec les bonnes adresses du type youtube.com/watch?v=, pas celle du type youtube.com/v/ID car elles vont toutes disparaitre à terme chez youtube.

coté css, les dimensions déclarées dans le formulaire sont maintenant envoyées à la classe media-content via le html, classe qui contient le conteneur de la vidéo. il faut donc avoir la classe media-content en position: relative et le conteneur de la vidéo en position:absolute en le "stretchant" à la classe media-content

Code CSS :
.media-content {
    position: relative;
    max-width: 100%;
    margin-bottom: 2em;
    text-align: center;
}
.media-content object,
.media-content embed,
.media-content video,
.media-content iframe,
.media-content [class$="-player"] {
    position: absolute;
    top: 0;
    height:100%;
    left: 0;
    width:100%;
}


ainsi .media-content défini les dimensions de l'espace d'affichage de la vidéo(width et heigh du formulaire) jusqu'au maximum de la largeur de son emplacement (max-width: 100%) et la vidéo rempli entièrement cet espace


Pour un support plus efficace, pensez à déclarer dans votre profil, le lien vers votre site
ban_wind
Site web    
MickaelFR Membre non connecté

Booster Fusée

Rang

Avatar

Inscrit le : 20/01/2014 à 11h01

Messages: 1669

Le 03/05/2020 à 12h29
Bonjour.

D'accord.

Bon, je crois que je vais tout supprimer, et tout refaire et re-personnalier.

Par contre, impossible d'éditer toutes les vidéos, j'en ai pour 6 mois :D

Je reviendrai ici après avoir bossé sur le module cet après midi :top

Merci
MickaelFR Membre non connecté

Booster Fusée

Rang

Avatar

Inscrit le : 20/01/2014 à 11h01

Messages: 1669

Le 03/05/2020 à 14h24
Re.

Bon, je n'ai pas regardé les erreurs, mais je suis confronté à un problème avec les images ..
Celles-ci sont bien dans la classe "cotent", mais à cause du float, l'image sort du cadre "content" .. Je n'arrive pas à l'intégrer correctement ..

annotation_2020-05-03_142143

annotation_2020-05-03_142241

Je viens de personnaliser tout juste les fichiers d'origine, donc cela ne vient pas du CSS.

Voici mon CSS en cas tout de même :

Code CSS :
/*
* Surchargez ce fichier dans votre thème pour personnaliser le module
* https://www.phpboost.com/wiki/structure-d-un-theme#paragraph-le-repertoire-modules
*/
 
a.media-flv {
    display: block;
    margin: 0.618em auto;
}
 
/* MODIFICATIONS */
 
@media (min-width: 980px) {
    .more {
        margin: 2em 0 2em 0;
    }
}
 
#content-media {
    background-color: #fff;
    padding: 1em;
    border-radius: 20px;
    box-shadow: 0px 0px 12px 0px #ddd;
}
 
#text-media {
    background-color: #fff;
    border-radius: 20px;
    box-shadow: 0px 0px 10px 0px #ccc;
    padding: 1em;
    margin-top: 2em;
}
 
/* FIN MODIFICATIONS */
MickaelFR Membre non connecté

Booster Fusée

Rang

Avatar

Inscrit le : 20/01/2014 à 11h01

Messages: 1669

Le 03/05/2020 à 14h53
Autre soucis ..

Avec fichiers d'origines ! J'ai juste modifié le CSS, et déplacer quelques div de place, tout en respectant les classes ! Donc fichier d'origine.

Avec un lien direct (navigateur)

La taille n'est pas respectée .. Le div content oui, mais pas la vidéo, qui passe en Iframe

annotation_2020-05-03_145147

Avec l'URL courte dans partager (Youtube toujours)

annotation_2020-05-03_145413

Avec erreur en archive :

Code TEXT :
Suggestion : Undefined index: mime_type
[0] /media/media_action.php:392


Pour que tout fonctionne normalement, je dois faire comme avant .. Remplacer le EMBED par V et je récupère la taille voulu dans les paramètres. Edité par MickaelFR Le 03/05/2020 à 14h59
babsolune Membre non connecté

Modérateur

Rang

Avatar

Equipe Graphique

Inscrit le : 16/05/2008 à 12h52

Messages: 2776

Le 03/05/2020 à 16h38
problème de dimension => refresh du cache navigateur
la video qui passe en iframe, c'est normal, ce n'est plus un fichier swf

problème de short link => mon erreur, il faut supprimer les "www." de la ligne 56 de media_constant.php, c'est 'youtu.be' et non 'www.youtu.be' (#OnNeFaitJamaisAssezDeTests => mis à jour sur github)

Citation :
Pour que tout fonctionne normalement, je dois faire comme avant .. Remplacer le EMBED par V et je récupère la taille voulu dans les paramètres.

https://demo.phpboost.com/media/media-0-2+youtube.php
refresh du cache du site ?

Pour ton problème d'image qui "déborde", 2 solutions:
- passer le conteneur (.content) en overflow: hidden
Code CSS :
.content {
    ...
    overflow: hidden;
}

- mettre un clear: both (mais pas que) sur le ::after du conteneur(.content::after)
Code CSS :
.content::after, .content::before {
    content: '';
    display: block;
    clear: both;
}


perso je préfère la deuxième (appliquée sur la future 5.3)


Pour un support plus efficace, pensez à déclarer dans votre profil, le lien vers votre site
ban_wind
Site web    
MickaelFR Membre non connecté

Booster Fusée

Rang

Avatar

Inscrit le : 20/01/2014 à 11h01

Messages: 1669

Le 03/05/2020 à 17h01
Salut.

Bon je pense que tout rentre dans l'ordre, il me faudra surveiller les erreurs

J'ai donc ajouté ceci (ton code), dans le media.css

Code CSS :
.content::after, .content::before {
    content: '';
    display: block;
    clear: both;
}


Et effectivement, on y voit bien plus clair !
Ce CSS désigne quoi exactement ? (Avec des mots simples :D) Car j'ia tenté je ne sais combien de chose, mais impossible de toruver la solution. Donc par exemple cotnent : ""; désigne quoi ?
Clear both sert à quoi ?

Merci à toi :)
babsolune Membre non connecté

Modérateur

Rang

Avatar

Equipe Graphique

Inscrit le : 16/05/2008 à 12h52

Messages: 2776

Le 03/05/2020 à 17h51
::before et ::after ont des pseudo-éléments de l'élément auxquels ils se rapportent, un genre d'enfants indissociables de l'élément et qui sont livrés avec
content:' ' defini le contenu de ces enfants, il est obligatoire même si ici il est vide;
display: block, c'est pour le forcer à prendre toute la largeur
clear: both, un genre de r.a.z. de toutes propriétés qui pourraient se trouver à gauche et à droite du pseudo-élément

donc en gros on nettoie au karsher et à la javel autour des enfants de l'élément ce qui a pour effet d'englober tout le contenu pour pas qu'il soit "mouillé ou délavé" et donc ici résoudre les problèmes dûs au float qui font sortir les éléments du flux


Pour un support plus efficace, pensez à déclarer dans votre profil, le lien vers votre site
ban_wind
Site web    
MickaelFR Membre non connecté

Booster Fusée

Rang

Avatar

Inscrit le : 20/01/2014 à 11h01

Messages: 1669

Le 03/05/2020 à 18h13
D'accord, merci beaucoup :)

J'ai surtout compris le display block, et le clear both :D Le reste c'est du chinois un petit peu :D

:top
John Membre non connecté

Booster Fronde

Rang

Avatar

Inscrit le : 03/08/2022 à 22h36

Messages: 2

Le 04/08/2022 à 16h07
Salut a tous ,
je viens d'avoir le même problème et je vous remercie par vos réponse sur le forum ici, j'ai néanmoins une autre préoccupation, quelqu'un sait comment référencer sa chaîne sur YouTube ?
Edité par John Le 08/08/2022 à 12h04


L' univers du web en un site internet
   
MickaelFR Membre non connecté

Booster Fusée

Rang

Avatar

Inscrit le : 20/01/2014 à 11h01

Messages: 1669

Le 05/08/2022 à 09h46
John :
Salut a tous ,
je viens d'avoir le même problème et je vous remercie par vos réponse sur le forum, j'ai néanmoins une autre préoccupation, quelqu'un sait comment se référencier sur YouTube ?


Bonjour.

A part les tags et les années .. Il n'y a pas grand chose à faire.
Répondre
Vous n'êtes pas autorisé à écrire dans cette catégorie
Annonces